nvidia driver

Home Forum Users Talks Applications and Scripts nvidia driver


This topic contains 3 replies, has 2 voices, and was last updated by  flavitu 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #2034
    • Topics: 32
    • Replies: 45
    • Post: 77

    How to install nvidia drivers in the “Pure”
    nvidia g.b.l-2.04
    There are several ways to install and I will describe three types of nvidia driver installation.
    The first thing that you should perform is find out your graphics card model.
    lspci -vnn | grep -i VGA -A 12
    Then update and upgrade package
    sudo aptitude update && sudo aptitude full-upgrade
    sudo apt-get update && sudo apt-get dist-upgrade

    1. Install additional drivers for nVidia graphics adapters. “ubuntu-drivers-common”

    sudo ubuntu-drivers list

    Will show all the driver packages which apply to your current system. You can then
    sudo ubuntu-drivers autoinstall

    to install all the packages you need, or you can do:
    sudo ubuntu-drivers devices

    to show you which devices need drivers, and their corresponding package names.

    2. Using proprietary drivers “PPA repository”

    sudo add-apt-repository ppa:xorg-edgers/ppa -y
    ‘sudo aptitude update’

    Either you can install the driver directly by installing a single package containing “nvidia” and the major version number ( 173, 304, 310, …).
    – 331 driver
    sudo apt-get install nvidia-331

    – 334 driver
    sudo apt-get install nvidia-334

    – install the latest version
    sudo apt-get install nvidia-current

    Verify the installation

    The last thing to do is verify that the nvidia drivers are loaded and working. Run the lspci command again and this time the kernel driver should show nvidia

    lspci -vnn | grep -i VGA -A 12

    Check the last line which says “kernel driver in use: nvidia”. This shows that nvidia drivers are now in action. Also check hardware acceleration with the glxinfo command
    glxinfo | grep OpenGL | grep renderer
    OpenGL renderer string: GeForce 210/PCIe/SSE2

    The OpenGL renderer string should be anything other than “MESA”. Then it indicates that the hardware drivers are being used for hardware acceleration.

    Removing the drivers

    Incase anything goes wrong after the installation, like you are not able to boot Ubuntu, then try removing the Nvidia drivers.

    Boot into the recovery console from the grub menu and then issue the following commands
    – remount root file system as writable
    mount -o remount,rw /

    – remove all nvidia packages
    apt-get purge nvidia*
    aptitude purge nvidia
    Additional Notes

    Many tutorials out there talk about blacklisting the nouveau driver. This is no longer necessary, since the nvidia driver would blacklist nouveau itself. This can be verified by checking the contents of nvidia driver files in the the modprobe.d directory.
    grep 'nouveau' /etc/modprobe.d/* | grep nvidia
    /etc/modprobe.d/nvidia-331_hybrid.conf:blacklist nouveau
    /etc/modprobe.d/nvidia-331_hybrid.conf:blacklist lbm-nouveau
    /etc/modprobe.d/nvidia-331_hybrid.conf:alias nouveau off
    /etc/modprobe.d/nvidia-331_hybrid.conf:alias lbm-nouveau off
    /etc/modprobe.d/nvidia-graphics-drivers.conf:blacklist nouveau
    /etc/modprobe.d/nvidia-graphics-drivers.conf:blacklist lbm-nouveau
    /etc/modprobe.d/nvidia-graphics-drivers.conf:alias nouveau off
    /etc/modprobe.d/nvidia-graphics-drivers.conf:alias lbm-nouveau off

    Note that the files “nvidia-331_hybrid.conf” and “nvidia-graphics-drivers.conf” have blacklisted nouveau.

    To check information about the nvidia driver module, use the commands lsmod, modprobe and modinfo
    lsmod | grep nvidia
    modprobe -R nvidia
    modinfo nvidia_XXX – XXX driver number “nvidia-331”

    So it looks like, I personally do not recommend the use of these methods in GoBang Linux.
    The second method is a great need for
    dependencies which will lead to the installation of gnome.

    3. And the most correct way to install closed nVidia graphics card driver in gbl “pure”

    nvidia gobang linux

    Visit http://www.nvidia.com/Download/index.aspx
    Fill in the details about your graphics card and system and then click Search. On the next page, it should tell you the correct driver version with a download link and additional information.
    Install required packages
    sudo apt-get install dkms fakeroot build-essential linux-headers-generic
    After you finish with this one, you should also blacklist the nouveau driver by editing this file with either:
    gksudo geany /etc/modprobe.d/blacklist-nouveau.conf

    sudo nano /etc/modprobe.d/blacklist-nouveau.conf

    If, by any chance, there is no blacklist-nouveau.conf present in /etc/modprobe.d/, you can save your file as blacklist-nouveau.conf when prompted.

    And you can also disable the Kernel Nouveau by typing these lines in a terminal window:
    echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf

    and after that
    sudo update-initramfs -u

    Now you can reboot your computer, and when you get to the login prompt, press Ctrl+Alt+F1 to exit to the terminal console. Login with your username and password.

    Go to the directory where you saved your nvidia driver using the command “cd” in the terminal console. Eg. cd nvidia considering that you are already in your user home directory after you login. You can use command “ls” to be able to see your exact driver’s name.

    To stop your display manager or the X server, you can type in the console this code:
    sudo /etc/init.d/slim stop
    And now you can finally install the nvidia driver.
    chmod u+x NVIDIA*
    sudo sh NVIDIA*

    Nvidia installer automatically installs the driver, and at the end it will ask you whether you want to save your new X configuration. Press Yes. After reboot and getting to your desktop and changing your NVIDIA settings as you please you should open a terminal window and type in this code:
    sudo nvidia-xconfig

    to save your new nvidia configuration in /etc/X11/xorg.conf.

    Finally, change the resolution Grub :yahoo:

    sudo geany /etc/default/grub
    Look for the line :
    Just underneath write the line :
    if this does not fix your problem replace “GRUB_GFXPAYLOAD_LINUX=auto” with:
    then update grub with this command line:
    sudo update-grub

    nvidai gobang linux

    You want to help in the development?
    Comments and suggestions welcome!


    • Topics: 5
    • Replies: 28
    • Post: 33

    I have ati in my both machines, but the info is very importanto for nvidia users.

    • Topics: 32
    • Replies: 45
    • Post: 77

    Hi, unfortunately I am not in possession of the machine with the ATI.
    It’s hard to provide a specific solution for such equipment.
    If you know the correct procedure to install the ATI driver, share it.

    You want to help in the development?
    Comments and suggestions welcome!


    • Topics: 5
    • Replies: 28
    • Post: 33

    In my case my video cards are unsupported by ATI so I use default radeon config provide by Ubuntu.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.